Tue. Jun 28th, 2022

Apple ha decidido eliminar las aplicaciones “antiguas y obsoletas” de la App Store. En un correo electrónico titulado “Aviso de mejora de la aplicación”, que se entregó a los desarrolladores de iOS y macOS, Apple ha declarado que eliminarán las aplicaciones que los desarrolladores no hayan actualizado “en un período de tiempo significativo”.

Desde que recibieron el correo electrónico, los desarrolladores se han dirigido a Twitter para llamar a Apple sobre esta nueva política y por qué puede ser perjudicial para los desarrolladores a pequeña escala. La razón principal por la que Apple quiere que los desarrolladores actualicen su aplicación es para que puedan portar sus aplicaciones a las API más recientes de Apple. Su razonamiento es que las versiones más nuevas de las aplicaciones basadas en las nuevas API mejorarían la experiencia del usuario en sus dispositivos más nuevos. Apple ha estado lidiando con varias denuncias y casos de comportamiento anticompetitivo, siendo el más renombrado de todos ellos el caso Epic vs. Apple. Varios desarrolladores de aplicaciones se han quejado de que, aunque Apple les ha dado a algunos desarrolladores la posibilidad de portar sus aplicaciones a la nueva API, ciertos desarrolladores de aplicaciones que han expresado su desdén por las políticas de Apple han eliminado sus aplicaciones sin previo aviso. Un desarrollador, Protopop Games, que tiene el nombre de usuario “protopop” en Twitter, señaló que entre las diferentes plataformas y diferentes API, se vuelve casi imposible para los desarrolladores de aplicaciones independientes desarrollar y mantener la aplicación en tantas plataformas diferentes.

También señaló que incluso una actualización anual tiene el potencial de interrumpir y romper una aplicación tan gravemente que no se ejecuta, lo que básicamente significaría que los usuarios dejarían de usar la aplicación para siempre.

Otro usuario, “erasmolbj”, ha señalado que algunas de las propias aplicaciones de Apple no se han actualizado durante años.

Los desarrolladores de aplicaciones independientes trabajan con un presupuesto ajustado y, obviamente, no pueden actualizar sus máquinas todos los años, cuando Apple anuncia una nueva MacBook Air o una MacBook Pro. Otra cosa tortuosa que Apple ha implementado aquí es el programa que los desarrolladores necesitan para transferir sus aplicaciones más antiguas a la API más nueva, que solo puede ejecutar macOS 10.12.6 o más reciente. No se puede utilizar ningún sistema que no se pueda actualizar a esta versión del sistema operativo.

Via: FirstPost

By Maria Montero

Me apasiona la fotografía y la tecnología que nos permite hacer todo lo que siempre soñamos. Soñadora y luchadora. Actualmente residiendo en Madrid.