Sat. Nov 26th, 2022

TL; DR Algunas personas informan que no pueden usar Google Wallet. La causa principal del problema es un error que afirma que el dispositivo está rooteado o que ejecuta un software no certificado. El software en cuestión podría ser el propio sistema de seguridad de Google. Si tiene problemas para usar Google Wallet, no está solo. Varias personas informan que experimentan un error que les impide usar la aplicación. Según lo descubierto por Android Police, algunos usuarios de Google Wallet informan en Reddit que no pueden usar Google Wallet. Estos usuarios parecen tener un problema de seguridad que hace que aparezca una notificación que indica que su dispositivo está rooteado o que ejecuta un software no certificado. A pesar de usar teléfonos Google Pixel y Samsung Galaxy no modificados, el aviso aparece cada vez que intentan usar Google Wallet. Ni siquiera las soluciones rápidas, como borrar el caché de Play Store, parecen funcionar. Como afirma Android Police, el problema podría estar relacionado con la API de certificación de SafetyNet, algo que Google usa para proteger los pagos cuando usa Google Wallet. Al usar Google Wallet, la certificación de SafetyNet La API realiza una verificación en el dispositivo para asegurarse de que no se vio comprometido de una manera que haría que la transmisión de información confidencial fuera riesgosa. Esto significa asegurarse de que el cargador de arranque, el programa que le dice a su teléfono qué sistema operativo ejecutar, esté bloqueado. Si su teléfono pasa la verificación, podrá realizar un pago con Google Wallet. Sin embargo, Google planea reemplazar la API de certificación de SafetyNet con una nueva API llamada Play Integrity para 2024. Si bien 2024 es la fecha límite para que las aplicaciones de terceros comienza a usar Play Integrity, es posible que Google ya haya comenzado a implementar la API en parte de su propio software. De acuerdo a Misaal Rahman, editor técnico de Esper, Google Wallet ya se está ejecutando en Play Integrity. Si la verificación de certificación de SafetyNet detecta la API de Play Integrity, es posible que SafetyNet considere un software no certificado de Play Integrity. Esto daría como resultado que la aplicación quedara inutilizable. Por el momento, no está claro qué está causando exactamente el error, pero esta explicación parece plausible. Tendremos que esperar hasta que Google proporcione una respuesta. Comentarios